Back to overview
Downtime
The JOD Tables application is currently unavailable.
Oct 31 at 12:18pm HDT
Affected services
tables.justorgdesign.com
Resolved
Oct 31 at 12:40pm HDT
All JOD systems are back up and running. We were experiencing issues with our service provider - all issues have been resolved.
Affected services
Updated
Oct 31 at 12:33pm HDT
We understand what the issue is and are working on a fix now.
Affected services
Created
Oct 31 at 12:18pm HDT
We are researching the issue now. This is our highest priority. We will update details here.
Affected services